Problems connecting GitHub.com source code manager in Semgrep AppSec Platform

Incident Report for Semgrep

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2025 - 17:45 UTC

Identified

We've identified the problem as a missing authentication refresh between Semgrep and GitHub that affects users in rare situations. If you're currently unable to connect your GitHub organization to Semgrep, please reach out to Semgrep Support for assistance until the fix is complete.
Posted Sep 12, 2025 - 23:39 UTC

Investigating

We are currently investigating reports from users that connecting to GitHub.com as a source code manager (SCM) in Semgrep AppSec Platform is unsuccessful.
Posted Sep 12, 2025 - 22:37 UTC
This incident affects: semgrep.dev (Dashboard).