Intermittent errors in the Semgrep AppSec Platform on some services

Incident Report for Semgrep

Resolved

This issue has been resolved, and the platform is currently stable.
Posted Jan 16, 2026 - 20:47 UTC

Monitoring

We have implemented a fix and are monitoring the platform for stability.
Posted Jan 15, 2026 - 22:28 UTC

Investigating

We have identified intermittent errors occurring on some platform services, and we are investigating.
Posted Jan 15, 2026 - 19:47 UTC
This incident affected: semgrep.dev (Dashboard).