Findings data out of date for organizations using combined Code/AI view

Incident Report for Semgrep

Resolved

All data has backfilled and the system is healthy.
Posted Mar 30, 2026 - 23:55 UTC

Update

Data backfill continues to progress, and realtime sync remains healthy.
Posted Mar 27, 2026 - 18:20 UTC

Update

Data backfill is now complete for most organizations. We are continuing to monitor the final syncs.
Posted Mar 26, 2026 - 23:43 UTC

Update

Realtime sync is now healthy. We are continuing to monitor the data backfill.
Posted Mar 26, 2026 - 19:38 UTC

Monitoring

Starting March 26 around 06:00 UTC, findings data in Semgrep AppSec Platform may have been out of date by up to 9 hours. We have implemented a fix and are monitoring as data backfills.
Posted Mar 26, 2026 - 15:27 UTC
This incident affected: semgrep.dev (Dashboard, API).