UI performance degraded for some organizations

Incident Report for Semgrep

Resolved

We've confirmed that UI and login issues are resolved.
Posted Mar 12, 2025 - 19:38 UTC

Monitoring

The fix is rolled out and we're monitoring to ensure functionality is restored.
Posted Mar 12, 2025 - 19:14 UTC

Update

As part of the remediation for the underlying issue, we made changes that temporarily impacted login for some users. This was expected and is self-resolving as the fix continues to roll out.
Posted Mar 12, 2025 - 19:01 UTC

Identified

We've identified the cause of the latency and are implementing a fix.
Posted Mar 12, 2025 - 18:44 UTC

Investigating

We're investigating reports of degraded performances across pages in Semgrep AppSec Platform for some organizations.
Posted Mar 12, 2025 - 18:34 UTC
This incident affected: semgrep.dev (Login/SSO, Dashboard).