Managed Scans fail-open checks delayed up to 20 minutes

Incident Report for Semgrep

Resolved

This issue has been resolved.
Posted Oct 16, 2025 - 00:43 UTC

Monitoring

We've applied a fix for the issue, and fail-open updates should now be occurring in a timely manner. We are monitoring for stability.
Posted Oct 16, 2025 - 00:35 UTC

Investigating

Check updates to Managed Scans that don't complete within the set Timeout value for "Fail open" are currently delayed up to 20 minutes. We are investigating the issue.
Posted Oct 16, 2025 - 00:24 UTC
This incident affected: semgrep.dev (Managed Scans).