Delayed on-demand Assistant analysis

Incident Report for Semgrep

Resolved

This issue has been resolved, and on-demand Assistant analyses are completing as expected.
Posted Oct 10, 2025 - 20:11 UTC

Monitoring

On-demand Assistant analysis is now processing successfully but latency is persisting. Some analysis requests from earlier in the day may have failed; we will attempt to retry these when the system is healthy.
Posted Oct 10, 2025 - 00:36 UTC

Identified

On-demand Assistant analysis from the Semgrep AppSec Platform is currently delayed. We have identified the issue and are working on a resolution.
Posted Oct 09, 2025 - 20:56 UTC
This incident affected: semgrep.dev (Dashboard).