Semgrep Docker release removed the bash shell, causing issues in CI

Incident Report for Semgrep

Resolved

The rollback is complete and we've confirmed that the latest Docker release has the bash shell available.
Posted Mar 21, 2024 - 22:20 UTC

Monitoring

The release has been rolled back, and we are monitoring to ensure the rollback is working as expected.
Posted Mar 21, 2024 - 21:19 UTC

Identified

We've identified an issue with the most recent release of the Semgrep Docker container which removed the bash shell, causing issues in CI for some users. We are working on a mitigation for the issue.
Posted Mar 21, 2024 - 21:16 UTC
This incident affected: semgrep.dev (Scans and CI/CD).