Delays for Managed scans fail-open process

Incident Report for Semgrep

Monitoring

We have implemented a change to allow faster processing of fail-open requests, and the delay has reduced to under 5 minutes. We are monitoring to ensure the system remains stable.
Posted Apr 14, 2026 - 00:46 UTC

Investigating

Since 22:00 UTC, some fail-open processes for unfinished Managed Scans may have been delayed up to 40 minutes. We are investigating the issue.
Posted Apr 14, 2026 - 00:02 UTC
This incident affects: semgrep.dev (Managed Scans).