Occasional Secrets scan failures and mis-attributed findings
Incident Report for Semgrep
Resolved
This incident has been resolved.
Posted Mar 02, 2024 - 02:27 UTC
Monitoring
We determined that since Friday, Feb 23 22:30 UTC, a bug related to Semgrep Secrets has caused a small number of scans to fail, and some Semgrep Secrets findings to appear as Semgrep Code findings. Only a small percentage of scans using Semgrep Secrets were affected. The issue has been addressed and future scans will not be affected. We are continuing to work to clean up the erroneous findings.
Posted Mar 01, 2024 - 20:42 UTC
This incident affected: semgrep.dev (Dashboard, Scans and CI/CD).