Semgrep AppSec platform failing to load

Incident Report for Semgrep

Resolved

This issue has been resolved and the platform is operating normally.
If you saw any scans for pull or merge requests hanging during this time, you can close and re-open the request, or add a commit, to start a new scan.
Posted Dec 11, 2024 - 19:14 UTC

Monitoring

We've applied fixes and are now monitoring results. The platform is able to load and appears healthy.
Posted Dec 11, 2024 - 17:41 UTC

Investigating

The AppSec platform is running slowly or failing to load, and we're investigating the issue. Some scans may be having trouble reporting back to the platform.
Posted Dec 11, 2024 - 17:20 UTC
This incident affected: semgrep.dev (Login/SSO, Dashboard, API, Scans and CI/CD, Managed Scans).