Degraded scan performance in CI and Semgrep Managed Scans

Incident Report for Semgrep

Resolved

This issue has been resolved. The system is now stable and scans are executing normally.
Posted Jan 09, 2026 - 23:27 UTC

Monitoring

We've identified and implemented several changes, and we are seeing recovery. We will continue to actively monitor.
Posted Jan 09, 2026 - 22:53 UTC

Update

We are continuing to investigate the cause of the issue.
Posted Jan 09, 2026 - 18:44 UTC

Investigating

We are currently investigating an issue with degraded scan performance in CI and Semgrep Managed Scans.
Posted Jan 09, 2026 - 17:02 UTC
This incident affected: semgrep.dev (Scans and CI/CD, Managed Scans).