Findings data display lagging behind realtime

Incident Report for Semgrep

Resolved

This issue has been resolved, and findings data is now displaying normally.
Posted Jul 20, 2026 - 22:58 UTC

Update

Backfill is continuing and lag has reduced to approximately 1 hour behind realtime. We continue to monitor to ensure progress.
Posted Jul 20, 2026 - 21:58 UTC

Monitoring

Processing of findings data has been delayed since approximately 03:20 UTC and is currently lagging approximately 3 hours behind realtime. The underlying cause has been addressed and we are monitoring to ensure the backlog is processed.
Posted Jul 20, 2026 - 20:07 UTC
This incident affected: semgrep.dev (Dashboard, API).