Interruption to Scans and Accessing Web App

Incident Report for Semgrep

Resolved

Resolved. All products were confirmed to be operational, but Engineering will remain on standby to respond to customer reported issues.
Posted Sep 22, 2026 - 19:37 UTC

Monitoring

Engineering initiated a rollback to fix issues with scans uploading findings preventing successful completion of Managed Scans and CI scans. We are verifying the fix before marking resolved.
Posted Sep 22, 2026 - 19:27 UTC

Identified

We are currently investigating issues with scans uploading findings which prevents the successful completion of scans. Additionally, we are aware of issues accessing the web user interface.
Posted Sep 22, 2026 - 19:24 UTC
This incident affected: semgrep.dev (Dashboard, API, Scans and CI/CD, Managed Scans).