Managed Scans: full project scans being associated with HEAD instead of the default branch name

Incident Report for Semgrep

Resolved

This incident has been resolved.
Posted May 20, 2026 - 02:52 UTC

Monitoring

We have deployed the fix and are monitoring.
Posted May 20, 2026 - 02:47 UTC

Identified

We have identified the issue and are working on a resolution.
Posted May 20, 2026 - 02:08 UTC

Investigating

We are currently investigating an issue where full project scans in Managed Scans are being associated with HEAD rather than the name of the default branch. This issue started around 16:00 UTC on May 19 and may result in unexpected new findings notifications, and some findings not being closed as expected.
Posted May 20, 2026 - 01:18 UTC
This incident affected: semgrep.dev (Managed Scans).