Elevated rate of errors when starting scans

Incident Report for Semgrep

Resolved

This issue has been resolved and scans are now starting normally.
Posted Dec 19, 2025 - 21:11 UTC

Monitoring

We have rolled out a fix and are seeing signs of recovery. We are continuing to monitor closely.
Posted Dec 19, 2025 - 21:04 UTC

Investigating

We've observed an increase in error rate when starting scans and we are investigating the cause.
Posted Dec 19, 2025 - 20:43 UTC
This incident affected: semgrep.dev (Scans and CI/CD).