Widespread errors on Semgrep AppSec Platform

Incident Report for Semgrep

Resolved

This issue has been fully resolved with a successful release.
Posted Aug 25, 2026 - 22:01 UTC

Monitoring

The release has been rolled back and the platform is now stable.
Posted Aug 25, 2026 - 19:28 UTC

Identified

A bad release is causing widespread failures in the Semgrep AppSec Platform.
Posted Aug 25, 2026 - 19:21 UTC
This incident affected: semgrep.dev (Dashboard, Scans and CI/CD).