Some managed full scans are not completing

Incident Report for Semgrep

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 00:33 UTC

Update

The issue is no longer affecting most users. We're continuing to monitor the long tail while minimizing further disruption over the US holiday weekend.
Posted Nov 27, 2025 - 05:30 UTC

Monitoring

We've deployed the fix and we're watching to ensure the problem is resolved.
Posted Nov 27, 2025 - 03:36 UTC

Identified

Managed full scans aren't completing in a subset of Semgrep organizations. We've identified the cause and are rolling out a fix.
Posted Nov 27, 2025 - 02:49 UTC
This incident affected: semgrep.dev (Managed Scans).