Reporting dashboard graphs not displaying

Incident Report for Semgrep

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 11:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2025 - 11:48 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 16, 2025 - 11:15 UTC

Investigating

We're currently investigating an issue where graphs are not displaying on the reporting dashboard page. The rest of the Semgrep platform is functioning normally. We're working on a fix and will provide updates as we make progress.
Posted Oct 16, 2025 - 10:54 UTC
This incident affected: semgrep.dev (Dashboard).