The Semgrep Registry and Database is currently experiencing an outage
Incident Report for Semgrep
Resolved
As of 00:08 UTC the outage has been resolved and all systems are back and operational.
Posted Aug 31, 2022 - 00:07 UTC
Monitoring
Engineering has performed a rollback and has blocked all changes as we actively monitor the stability of our services and investigate into the root cause.
Posted Aug 31, 2022 - 00:05 UTC
Investigating
We are currently investigating in some database instability that is causing partial outages within both the App Dashboard and the Registry. Our engineering team is actively investigating this. We will update here as we make progress.
Posted Aug 30, 2022 - 23:36 UTC
Update
Engineering is actively looking into monitoring the issue and we will continue to update our status as we resolve the issue.
Posted Aug 30, 2022 - 23:11 UTC
Update
We are continuing to monitor the implemented fix for any further instabilities or issues.
Posted Aug 30, 2022 - 22:12 UTC
Monitoring
We are currently monitoring a fix that has been implemented to resolve the Semgrep Registry outage. For those who may have had scans running during 20:32 - 21:03 UTC, your scans may have failed open and not posted findings.
Posted Aug 30, 2022 - 21:25 UTC
Investigating
The Semgrep Registry is currently experiencing an outage. Our team is actively investigating and we expect to resolve this issue shortly. We’ll update here as we make progress.
Posted Aug 30, 2022 - 21:05 UTC
This incident affected: semgrep.dev (Dashboard, Registry).