Semgrep scans failing due to connectivity issues with AWS STS (Security Token Service)
Incident Report for Semgrep
Resolved
The AWS STS outage issue has been mitigated, and semgrep scans should be healthy and operational again.
Posted Aug 29, 2024 - 14:40 UTC
Monitoring
Earlier today, Semgrep scans were failing due to an AWS STS outage, which resulted in SSL validation errors and connectivity issues. AWS has been actively investigating the issue, and the situation is showing signs of improvement.

With the ongoing recovery, we expect services to stabilize. We will continue to monitor the issue.
Posted Aug 29, 2024 - 10:10 UTC
This incident affected: semgrep.dev (Scans and CI/CD).