Approximately 4% of scheduled Managed Scans failing to complete

Incident Report for Semgrep

Resolved

This issue has been resolved, and scans are completing normally.
Posted Dec 03, 2025 - 01:00 UTC

Monitoring

We've released a fix for the issue and are monitoring the results. Scan success rate currently appears normal and steady.
Posted Dec 02, 2025 - 23:46 UTC

Update

We've applied a mitigation that has reduced the failure rate, and are continuing to investigate the root cause.
Posted Dec 02, 2025 - 21:58 UTC

Investigating

We've identified an increase in incomplete scheduled scans (full repo scans) in Managed Scans, and we are investigating.
Posted Dec 02, 2025 - 20:08 UTC
This incident affected: semgrep.dev (Managed Scans).