Delays in Managed Scans, PR/MR comments

Incident Report for Semgrep

Resolved

This issue has been resolved, and Managed Scans are being triggered normally.
For any scheduled scans that did not run during this period, use the "Run a scan" option in the Semgrep AppSec Platform to initiate a new scan as needed.
Posted Apr 02, 2025 - 21:57 UTC

Monitoring

We've identified that the primary impact of the issue was scheduled Managed Scans for all tenants not initiating during this period. Other services, including Managed Scans on PRs and MRs, may only have experienced a slight delay. We have applied a fix for the issue and are now monitoring to ensure the platform is healthy.
Posted Apr 02, 2025 - 21:43 UTC

Identified

Since approximately 20:15 UTC, Managed Scans and PR/MR comments are delayed and some may have failed. We have identified the issue and are working to restore full functionality.
Posted Apr 02, 2025 - 21:23 UTC
This incident affected: semgrep.dev (Scans and CI/CD, Managed Scans).