Degraded scan start and completion performance in CI and Semgrep Managed Scans

Incident Report for Semgrep

Resolved

This issue has been resolved, and scans are starting and completing normally.
Posted Feb 12, 2026 - 17:54 UTC

Monitoring

We have made changes to improve service availability and scans are now able to start and complete as expected. We will continue to monitor.
Posted Feb 12, 2026 - 17:29 UTC

Investigating

We are currently investigating an issue with degraded performance of scan start and completion in CI and Semgrep Managed Scans.
Posted Feb 12, 2026 - 17:09 UTC
This incident affected: semgrep.dev (Scans and CI/CD, Managed Scans).