Some SMS projects with diff scanning configured are not scanning

Incident Report for Semgrep

Resolved

No further errors have been observed. Please reach out to support if you're seeing unexpected behavior around diff scans in PRs with Managed Scanning
Posted Aug 04, 2024 - 07:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2024 - 03:48 UTC

Identified

We've identified the source of the issue and are working on a fix.
Posted Aug 03, 2024 - 02:21 UTC

Investigating

It appears this started on July 30 and is only impacting some customers.
Posted Aug 03, 2024 - 00:51 UTC
This incident affected: semgrep.dev (Scans and CI/CD).