Logins are failing for users via GitHub auth

Incident Report for Semgrep

Resolved

This incident has been resolved.
Posted May 20, 2026 - 18:18 UTC

Update

This incident has been resolved.
Posted May 20, 2026 - 18:17 UTC

Monitoring

We have rolled out a fix, and logins are now working as expected. We are closely monitoring to ensure continued stability.
Posted May 20, 2026 - 17:49 UTC

Identified

We are currently observing login issues using GitHub auth. Our team has identified the issue and is currently working on a fix. SSO logins are working as expected and are not impacted.
Posted May 20, 2026 - 17:34 UTC
This incident affected: semgrep.dev (Login/SSO).