Occasional latency issues in Semgrep AppSec Platform

Incident Report for Semgrep

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 18:57 UTC

Monitoring

We've mitigated the source of latency and are monitoring to ensure the problem is resolved.
Posted Jun 13, 2025 - 18:31 UTC

Investigating

We're investigating an issue with occasional latency increases in Semgrep AppSec Platform. Platform responsiveness is generally normal but there may be brief periods where the platform loads slowly or some requests time out.
Posted Jun 11, 2025 - 16:43 UTC
This incident affected: semgrep.dev (Login/SSO, Dashboard, API).