Findings from semgrep-legacy rules
Incident Report for Semgrep
Resolved
This incident has been resolved.
Posted Jan 23, 2024 - 01:07 UTC
Investigating
On Jan 20-21, 2024 a handful of semgrep-legacy rules were added to actively running semgrep rulesets, creating new and erroneous findings for users who had configured those rulesets. We have patched the problem, so these findings will no longer appear in scans. We are also actively working on a patch to remove these findings without users needing to take action.
Posted Jan 22, 2024 - 18:32 UTC
This incident affected: semgrep.dev (Registry, Scans and CI/CD).