Issues with creating private app for GitHub.com source code manager connections

Incident Report for Semgrep

Resolved

This issue has been resolved, and app creation requests are succeeding.
Posted Sep 16, 2025 - 00:26 UTC

Monitoring

A fix has been implemented and we are now seeing successful app creations. We will continue to monitor to confirm the fix.
Posted Sep 15, 2025 - 21:54 UTC

Identified

We've identified the source of the issue and are working on a fix.
Posted Sep 15, 2025 - 19:55 UTC

Investigating

We are currently investigating issues with creating a private app (for code access) when connecting to GitHub.com as a source code manager.
Posted Sep 15, 2025 - 19:17 UTC
This incident affected: semgrep.dev (Dashboard).