This issue has been resolved. No new Managed Scans since the fix have encountered an unexpected exit code 7.
If you are not using Managed Scans and encounter an unexpected scan exit code 7, please re-attempt the scan with Semgrep version 1.142.3 or earlier. If you continue to encounter issues, contact Semgrep Support.
Posted Nov 24, 2025 - 23:30 UTC
Update
Most scans are now completing successfully. Some longer-running scans may still exit with code 7. We are continuing to monitor.
Posted Nov 24, 2025 - 21:13 UTC
Monitoring
We have released a fix and are now monitoring the results. We are seeing previously affected scans completing successfully.
Posted Nov 24, 2025 - 20:53 UTC
Investigating
We've seen that some scans are failing with exit code 7, indicating an issue with a rule. We are investigating the cause.
Posted Nov 24, 2025 - 18:52 UTC
This incident affected: semgrep.dev (Scans and CI/CD, Managed Scans).