Investigating issues with pull request checks and repository scans

Incident Report for Semgrep

Resolved

This issue has been resolved, and scans have returned to normal operation.
Posted Mar 06, 2026 - 16:18 UTC

Monitoring

We've identified the root cause of the issue that was affecting repository scans and pull request checks, and a fix has now been rolled out. We are now monitoring the results to make sure everything is running smoothly.
Posted Mar 06, 2026 - 15:47 UTC

Update

We are continuing to investigate this issue.
Posted Mar 06, 2026 - 12:24 UTC

Investigating

We are investigating reports of issues affecting repository scans and pull request checks. Some customers may see scans not starting or checks not appearing on pull requests.

We are investigating and will share updates as more information becomes available.
Posted Mar 06, 2026 - 12:04 UTC
This incident affected: GitHub (GitHub Pull Requests) and semgrep.dev (Scans and CI/CD, Managed Scans).