semgrep.dev website timeouts

Incident Report for Semgrep

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:31 UTC

Identified

We have identified an issue with loading the semgrep.dev website due to an outage with an upstream provider. Users will experience 504 Gateway Timeout errors until this provider outage is resolved.

The Semgrep AppSec Platform is not impacted, but users that rely on navigating to semgrep.dev in order to log in to the platform will be unable to do so. As a workaround, please navigate directly to `semgrep.dev/login` in the meantime.
Posted Oct 20, 2025 - 15:44 UTC
This incident affected: semgrep.dev (Login/SSO).