Incomplete Semgrep 1.176.1 release: PyPI installs cannot use Pro Engine

Incident Report for Semgrep

Resolved

This issue has been resolved. The Pro Engine can be installed and used normally after installing Semgrep 1.176.1 via PyPI.
Posted Sep 04, 2026 - 23:38 UTC

Investigating

An incomplete patch release of Semgrep 1.176.1 has left installations of this version using PyPI unable to use the Pro Engine.

We recommend explicitly installing version 1.175.1 or 1.176.0 as we work to resolve this issue.
Posted Sep 04, 2026 - 23:13 UTC