Some Managed Scans not starting

Incident Report for Semgrep

Resolved

This issue is resolved, and Managed Scans are continuing to run normally.
Posted Jul 10, 2025 - 19:37 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 10, 2025 - 18:55 UTC

Monitoring

Managed Scans are now running normally, including lockfile-less scans, and we are continuing to monitor to ensure ongoing health.
Posted Jul 10, 2025 - 18:54 UTC

Update

We're now observing nearly normal service. Some lockfile-less scans have been running without this capability, but we expect to restore this shortly as well.
Posted Jul 10, 2025 - 17:29 UTC

Identified

We've identified an issue with some Managed Scans not starting, beginning at 16:50 UTC. We have identified a fix and are rolling it out. Normal service is resuming.
Posted Jul 10, 2025 - 17:05 UTC
This incident affected: semgrep.dev (Managed Scans).