Some CI Scans are not completing successfully

Incident Report for Semgrep

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 13:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2026 - 12:11 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 08, 2026 - 11:18 UTC

Investigating

We're aware of an issue where CI scans are not completing or taking a long time to do so.

You may see scans getting stuck on the "Uploading scan results" or "Finalizing scan" stages.
Posted Jan 08, 2026 - 10:40 UTC
This incident affected: semgrep.dev (Scans and CI/CD).