Some scheduled managed scans are not starting

Incident Report for Semgrep

Resolved

This incident has been resolved. All projects with scheduled scans enabled should be scanned in the next 24 hours.
Posted Jun 07, 2025 - 17:55 UTC

Monitoring

We'll continue to monitor scan managed scheduling over the weekend.
Posted Jun 07, 2025 - 04:16 UTC

Identified

We've identified the source of the problem and we're deploying a fix.
Posted Jun 07, 2025 - 03:17 UTC

Update

While we continue to investigate the root cause of the issue, we're also rolling out a catchup task to ensure missed scans are rescheduled.
Posted Jun 07, 2025 - 01:38 UTC

Investigating

We're currently investigating an issue that has been preventing some managed scans from starting on schedule.
Posted Jun 06, 2025 - 22:24 UTC
This incident affected: semgrep.dev (Managed Scans).